The Triumph Dolomite Club - Discussion Forum

The Number One Club for owners of Triumph's range of small saloons from the 1960s and 1970s.
It is currently Wed Jun 29, 2022 9:37 pm

All times are UTC




Post new topic Reply to topic  [86 posts ]  Go to pagePrevious123456
Author Message
PostPosted:Sat Mar 05, 2022 11:09 am 
Offline
TDC Member
User avatar

Joined:Sun Dec 08, 2013 8:03 am
Posts:244
Location:High Wycombe
100% agree - progress is progress. Especially with these custom cars, if one single nut takes a whole weekend and you’re happy with the result then it’s time we’ll spent !!


Top
   
PostPosted:Sun Mar 06, 2022 2:31 pm 
Offline
Future Club member hopefully!
Future Club member hopefully!

Joined:Fri Sep 11, 2015 11:02 am
Posts:322
Quote:

Have you used relays to the coil packs ? when i was looking in to fitting a Turbo to the Sprint the Log type manifold had good reports

Dave
Originally I hadn’t, I just wired them up to the bottom fuse but that meant that the power for the coils, all 40 amps, was going through the ignition switch. Since that’s probably not the best idea, I’m now running a 40 amp fuse which will provide the power to them.

And yes, log style manifolds work really well on turbo-builds as flow isn’t as important response time. For my NA build, i would prefer a tubular style as to prioritise scavenging. I ran some calcs id found online for proper header length and I ended up at something like 1.2m for the stock cams which is a bit longer than I think can fit under the bonnet so I’m gonna be running much shorter ones.
Quote:
Any progress is progress in my book.

I’m also going to run mine with a log style exhaust manifold.
Once everything is in and working.

I’ll make a 3D printed exhaust bends (You can by a kit already but as I have a 3D printer why not knock them up myself) to mock up a equal length long exhaust manifold.
Then get it made in possibly Stainless Steel.

I’ve completely changed the position of my steering rack.
It’s now a Escort Mk 1 quick rack and sits in front of the subframe cross member.

Also picked up a rear brake disc kit.
Yeah, 1000%, progress is progress, even if it means taking a small step back to take two steps forward.

I have been printing small sections to check fitment and have looked up making a set of those header maker things.

And I have tried to leave as much of the car alone as possible so that I don’t have to do the DVLA inspection for new cars. As long as I leave the chassis, suspension, and steering alone,I should be ok

_________________
So many ideas... So little budget... So little time.


Top
   
PostPosted:Sat Mar 12, 2022 6:01 pm 
Offline
Future Club member hopefully!
Future Club member hopefully!

Joined:Fri Sep 11, 2015 11:02 am
Posts:322
Slightly more progress update

One of the things I need to sort is the alternator. The Jag one is fixed to the engine rigidly and the tensioner isn’t usable and trying to use it and the water pump means that the belt is routed in the most convoluted way. To remedy this, I’ve gone to an electric water pump from a BMW and replaced the alternator with one that can swing so it can tension itself.

As the passenger side engine mounts I’ve made takes up the available mounts on the passenger side, I’ve had to put it on the drivers side. This is a bit tricky as preferably I’d want that area free for exhausts and the steering column AND the starter motor are also on this side of the engine.

But this is what I’ve came up with. I’ll be getting the mount plates plasma cut to save time and energy. I’m going to get the sump trimmed down which will allow me to run the alternator hinge bolt closer to the engine, which will let me run the alternator more horizontally and free up a little bit more space.
Image

I am also debating having a new sump printed so I could incorporate the jingle point in there and put the alternator even lower. I’m not worried about it being too low as it’s all hidden behind the Sprint front lip as well as I’m round to run a sump guard and under tray.

_________________
So many ideas... So little budget... So little time.


Top
   
PostPosted:Mon Apr 11, 2022 8:29 am 
Offline
Future Club member hopefully!
Future Club member hopefully!

Joined:Fri Sep 11, 2015 11:02 am
Posts:322
Well, it’s been a month of ups and downs on this.

The good news is, is that I got the wiring for the ECU damn near complete and was ready for me to start going through calibration and then starting!!…

Then as I plugged it in, this happened

Image

The diode leading to the voltage regulator of the Speeduino exploded, taking some of the board with it. The board is now toast so having to wait on getting a new one to swap over all the components from my old one (minus exploded diode). A relatively cheap fix but one that takes a long time to sort.

In other news, I’ve managed to sort out a 3D scanner so I’ll be hard at work creating a load of scans to help with some of the more difficult tasks like exhaust routing.

I’ve got about half a dozen other projects on so progress has been quite slow, but hopefully once I get that new board in, I’ll get the drive back to get this thing running

_________________
So many ideas... So little budget... So little time.


Top
   
PostPosted:Fri May 20, 2022 8:43 am 
Offline
Future Club member hopefully!
Future Club member hopefully!

Joined:Fri Sep 11, 2015 11:02 am
Posts:322
Well, I got some pretty big news.

After months of ecu problems in which I had to buy a whole new ecu board and components, I got it into the car. And after three days messing around with settings and chasing small issues like loose connectors and fuel priming issues, I got the car running.

And it sounds

MEGA.

https://www.instagram.com/tv/CdlyavBKRR ... MyMTA2M2Y=

It doesn’t have any headers yet, so they’re next on the list. I’m also replacing the rear axle with that from an Escort, just have to recreate the Dolomite mountings. The outer ones are pretty simple, the inner ones are a right arse to make but with the help of some scans of the axle, I got a template 3D printed out which will let me use a rose joint instead of the sandwiched bush it normally has. At this rate, I might be driving it by years end, but I suppose i aimed to get it running at Christmas and I’m 5 months late for that so who knows.

Anyway, that’s all for now, next update won’t be anywhere near as good but I’m sure it’ll be worth it.

_________________
So many ideas... So little budget... So little time.


Top
   
PostPosted:Fri May 20, 2022 12:09 pm 
Offline
TDC Member

Joined:Mon Apr 29, 2019 9:31 pm
Posts:106
Location:Oxfordshire
Nice one! Didn't realise you were using a speeduino as well. What are timing sensors like on the jag v6? crank + cam? hall + VR i guess if so? What sort of tooth pattern, and did you have to write some custom firmware or is it similar to say a zetec? Also, are you fully sequential ignition and injection with a dropbear or are you running it paired on a UA4c/0.3/0.4?

_________________
1973 2-door honeysuckle Triumph Toledo 1300 Thread here


Top
   
PostPosted:Fri May 20, 2022 12:39 pm 
Offline
Future Club member hopefully!
Future Club member hopefully!

Joined:Fri Sep 11, 2015 11:02 am
Posts:322
Quote:
Nice one! Didn't realise you were using a speeduino as well. What are timing sensors like on the jag v6? crank + cam? hall + VR i guess if so? What sort of tooth pattern, and did you have to write some custom firmware or is it similar to say a zetec? Also, are you fully sequential ignition and injection with a dropbear or are you running it paired on a UA4c/0.3/0.4?
Timing sensors are both VR, one on the crank and one on both intake cams. I’m only using the crankshaft sensor.

Trigger wheel is the standard 36-1 that’s fairly standard across Ford at the time. The sensor offset (crank rotation before the missing tooth passes the sensor) is around 60 degrees BTDC.

Just standard firmware on a 0.4.4c board, I have it set up as paired injection and ignition so I only use 3/4 injector and ignition outputs. I’d ideally like more but for the price, you can’t compete. I’m thinking of either stepping up to an Emerald or a Haltech ECU long in the future but for now, this works just fine. I bought my kit about a year ago or so, just before the dropbear went into testing so by the time it comes out properly, it’ll be too late.

The kit was really good but was let down by my own idiocy. I bought a 40 pin connector and solders it in only to realise that the wires were too big for the pins, so desoldered as best I could and soldered the wires in directly, but somewhere I shorted the board out so when I plugged it into the car, it blew up the diode going into the voltage regulator and burst the copper off the board so went and bought a new board and transferred all the working components over and doing that two of the capacitors fell apart :evil: but it works now. I did forget about the ignition jumper and spent a day chasing ignition issues only for it to be that, which is why I’m the video there’s so much smoke, it’s all the fuel and easy start I’d put down the bores. That and the oil is put in to keep the bores from rusting too much.

_________________
So many ideas... So little budget... So little time.


Top
   
PostPosted:Fri May 20, 2022 1:26 pm 
Offline
TDC Member

Joined:Mon Apr 29, 2019 9:31 pm
Posts:106
Location:Oxfordshire
Quote:
Quote:
Nice one! Didn't realise you were using a speeduino as well. What are timing sensors like on the jag v6? crank + cam? hall + VR i guess if so? What sort of tooth pattern, and did you have to write some custom firmware or is it similar to say a zetec? Also, are you fully sequential ignition and injection with a dropbear or are you running it paired on a UA4c/0.3/0.4?
Timing sensors are both VR, one on the crank and one on both intake cams. I’m only using the crankshaft sensor.

Trigger wheel is the standard 36-1 that’s fairly standard across Ford at the time. The sensor offset (crank rotation before the missing tooth passes the sensor) is around 60 degrees BTDC.

Just standard firmware on a 0.4.4c board, I have it set up as paired injection and ignition so I only use 3/4 injector and ignition outputs. I’d ideally like more but for the price, you can’t compete. I’m thinking of either stepping up to an Emerald or a Haltech ECU long in the future but for now, this works just fine. I bought my kit about a year ago or so, just before the dropbear went into testing so by the time it comes out properly, it’ll be too late.

The kit was really good but was let down by my own idiocy. I bought a 40 pin connector and solders it in only to realise that the wires were too big for the pins, so desoldered as best I could and soldered the wires in directly, but somewhere I shorted the board out so when I plugged it into the car, it blew up the diode going into the voltage regulator and burst the copper off the board so went and bought a new board and transferred all the working components over and doing that two of the capacitors fell apart :evil: but it works now. I did forget about the ignition jumper and spent a day chasing ignition issues only for it to be that, which is why I’m the video there’s so much smoke, it’s all the fuel and easy start I’d put down the bores. That and the oil is put in to keep the bores from rusting too much.
Fair play, sounds good! I know dropbear boards are really hard to find atm and have heard that fully sequential is overkill anyway, past a certain RPM it is basically batch fire anyway. I guess you had to use a VR conditioner for your crank sensor? I am using a 0.4.3c for mine, though i've barely started, but it's nice to see i'm not alone in using one. I haven't had any shorting issues just yet but i've barely done anything besides set it up with the sensors etc. I'll be using in the standard 1300 engine.

What's the plan after the manifolds are on, auto tune through tuner studio I guess? Let us know if it's fairly reliable!

_________________
1973 2-door honeysuckle Triumph Toledo 1300 Thread here


Top
   
PostPosted:Fri May 20, 2022 3:00 pm 
Offline
Future Club member hopefully!
Future Club member hopefully!

Joined:Fri Sep 11, 2015 11:02 am
Posts:322
Quote:

Fair play, sounds good! I know dropbear boards are really hard to find atm and have heard that fully sequential is overkill anyway, past a certain RPM it is basically batch fire anyway. I guess you had to use a VR conditioner for your crank sensor? I am using a 0.4.3c for mine, though i've barely started, but it's nice to see i'm not alone in using one. I haven't had any shorting issues just yet but i've barely done anything besides set it up with the sensors etc. I'll be using in the standard 1300 engine.

What's the plan after the manifolds are on, auto tune through tuner studio I guess? Let us know if it's fairly reliable!
Yeah, dual channel so I could in theory use that instead of the crank but the issue is the cam trigger wheel is 4-1-1, which isn’t supported. My tip would be to work out wiring/connector layout before soldering anything into the outputs, so you don’t have to try and solder through pin holes full of solder lmao.

And for tuning, I have a bit of an ignition and injection tune based of an MX5 to get it running and I’ll just adjust that as needed when I get it driving about.

_________________
So many ideas... So little budget... So little time.


Top
   
PostPosted:Fri May 20, 2022 4:48 pm 
Offline
TDC Member

Joined:Mon Dec 12, 2016 9:53 pm
Posts:1433
Location:Harrow Middlesex
Quote:
Well, I got some pretty big news.

After months of ecu problems in which I had to buy a whole new ecu board and components, I got it into the car. And after three days messing around with settings and chasing small issues like loose connectors and fuel priming issues, I got the car running.

And it sounds

MEGA.

https://www.instagram.com/tv/CdlyavBKRR ... MyMTA2M2Y=

It doesn’t have any headers yet, so they’re next on the list. I’m also replacing the rear axle with that from an Escort, just have to recreate the Dolomite mountings. The outer ones are pretty simple, the inner ones are a right arse to make but with the help of some scans of the axle, I got a template 3D printed out which will let me use a rose joint instead of the sandwiched bush it normally has. At this rate, I might be driving it by years end, but I suppose i aimed to get it running at Christmas and I’m 5 months late for that so who knows.

Anyway, that’s all for now, next update won’t be anywhere near as good but I’m sure it’ll be worth it.
Well done getting it running, still not got round to buy my ECU


Top
   
PostPosted:Sat May 21, 2022 10:02 am 
Offline
TDC Member
User avatar

Joined:Wed Oct 04, 2006 8:49 pm
Posts:899
Location:Sutton,Surrey.
Hats off to you sir.

Freaking Outstanding.

_________________
2009 Mini Clubman Cooper S Daily Driver.
1980 Dolomite Sprint with a touch of BLTS
Balanced Lightened and Tweaked 13B Rotary and SuperCharged.
Rebuilding the Sprint time taken so far, 111Hrs@15/12/2020
212Hrs @31/12/2021
261@Hrs @ 13/06/2022
Member TDC no 0471

Project 13B Sprint now back on.


Top
   
Display posts from previous: Sort by 
Post new topic Reply to topic  [86 posts ]  Go to pagePrevious123456

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited