The Triumph Dolomite Club - Discussion Forum

The Number One Club for owners of Triumph's range of small saloons from the 1960s and 1970s.
It is currently Thu Sep 19, 2019 5:24 pm

All times are UTC




Post new topic  Reply to topic  [ 1 post ] 
Author Message
PostPosted: Tue Jun 11, 2019 9:50 am 
Offline
TDC Member

Joined: Wed Aug 19, 2009 9:26 am
Posts: 195
Hi All,
I really appreciate all the info and guidance you've all given recently, I do feel a pang of guilt as I generally only come on the forum to ask for help rather than helping others. One day when my lifes a little quieter I hope to repay the debt!

Anyway, once again I could use a little help!

My Sprint recently developed an odd vibration between 2.5 and 3k revs. It's more like a buzz but I can also feel it in the car. My car is poly bushed and has AVO coilovers so it's noisier than usual anyway but this noise is new.

I think it's the transmission. Revving the engine when stationery doesn't lead to any vibration, it only happens when moving. There also seems to be a fair amount of shunt in the drive train at low speeds. Selecting gears is ok with no issues and the OD engages/disengages easily.
When stationery I also get a change in noise when I dip the clutch so I think the release bearing is tired. I can also get a metallic 'thunk' when engaging reverse sometimes.

Am I looking at getting the box rebuilt?

Lots of info but as always any information or guidance will be greatly appreciated.

Cheers
Alex


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: Google [Bot] and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited