The Triumph Dolomite Club - Discussion Forum
http://forum.triumphdolomite.co.uk/

"MyGarage" version 1.8
http://forum.triumphdolomite.co.uk/viewtopic.php?t=10668
Page 2 of 2

Author:  gmsclassics [ Fri Sep 29, 2023 5:29 am ]
Post subject:  "MyGarage" version 2.2 software has died - Any help much appreciated

Wasn't sure whether to reopen this 2009 thread or start a new one, but....

I've been running this software since 2008 (now on v2.2 I think) and despite having to update the SQL database software with a change of computer about 5 years ago, it has worked perfectly - I now have or rather had a huge amount of history. Had, as a few days ago the software has simply died on me - this was after my PC was doing a large amount of updating. Now all I get is the outline of the small startup screen for about ten seconds, which then disappears and nothing.

I've tried to unsuccessfully to get hold of Adrian Fletcher by email. Once got a reply to say the mailbox was full. Also now see the website has disappeared in the last few days.

If anyone can offer any help or ideas as to how I might resurrect it, I would be very grateful. I have a backup taken some six or so months ago, but having looked at that I have no idea how to restore the software, or the data and whether or not that is going to help get it working again.

Any help much appreciated.

Geoff

Author:  ClassicFan [ Fri Sep 29, 2023 8:32 am ]
Post subject:  Re: "MyGarage" version 2.2 software has died - Any help much appreciated

Quote:
If anyone can offer any help or ideas as to how I might resurrect it, I would be very grateful. I have a backup taken some six or so months ago, but having looked at that I have no idea how to restore the software, or the data and whether or not that is going to help get it working again.

Any help much appreciated.

Geoff
Assuming your running in MS Windows it's likely the programme is 32 bit due to the age of it, so have you tried settig it to run in 'compatibility' mode for an older windows version?

Author:  jackharper [ Fri Sep 29, 2023 9:36 pm ]
Post subject:  Re: "MyGarage" version 1.8

I have no idea how the software works internally, but if it relies on an SQL instance i'd guess it'd all be stored in there if you are just aiming to make a backup of the data. It may even be human readable. You could use something like SQL Server Management Studio (GUI tool for viewing database tables etc) to view/backup the data?

as far as getting the software running again, v1.8 looks like it's screenshotted on WinXP, so might be tricky to run on a recent version of Windows. As suggested, compatibility mode is OK (right click the .exe -> Properties -> compatibility on Win10 at least)

failing that, could try booting an XP virtual machine and copying the database over to it?

Author:  gmsclassics [ Sat Sep 30, 2023 5:10 am ]
Post subject:  Re: "MyGarage" version 2.2

Apologies, I should have given more precise information about the software, including the database and PC I am running it on, which is the same since I transferred the software to in June 2018 after the last PC died. At this time I had to update the MS SQL server software to the 2016 version and this is what I last discussed with Adrian Fletcher at that time.

So, PC on which the software (version2.2G) has been running successfully up until a week ago is:

Dell OptiPlex (Intel(R) Core(TM) i5-4590S CPU @ 3.00GHz, 3.00 GHz 64-bit operating system, x64-based processor, running Windows 10 Pro, version 22H2, installed 22/‎11/‎2020. Database is Microsoft SQL Server 2016 (Media X64). Nothing else has changed other than Windows has been running its regular updates automatically.

I have tried running the compatibility settings mode and that made no difference. Unfortunately, I don't have an old pc / laptop to try running it on. I haven't tried to extract the data from the database, would rather leave that as a last resort.

Any other ideas?

Geoff

Author:  ClassicFan [ Sat Sep 30, 2023 9:40 am ]
Post subject:  Re: "MyGarage" version 1.8

OK have you tried rolling windows itself back to a version that you know ran the programme OK?

MS are dropping support for Win 10 in a couple of years but at leat you might get things running again until a proper solution can be found.

Author:  jackharper [ Tue Oct 10, 2023 11:37 am ]
Post subject:  Re: "MyGarage" version 1.8

Quote:
Apologies, I should have given more precise information about the software, including the database and PC I am running it on, which is the same since I transferred the software to in June 2018 after the last PC died. At this time I had to update the MS SQL server software to the 2016 version and this is what I last discussed with Adrian Fletcher at that time.

So, PC on which the software (version2.2G) has been running successfully up until a week ago is:

Dell OptiPlex (Intel(R) Core(TM) i5-4590S CPU @ 3.00GHz, 3.00 GHz 64-bit operating system, x64-based processor, running Windows 10 Pro, version 22H2, installed 22/‎11/‎2020. Database is Microsoft SQL Server 2016 (Media X64). Nothing else has changed other than Windows has been running its regular updates automatically.

I have tried running the compatibility settings mode and that made no difference. Unfortunately, I don't have an old pc / laptop to try running it on. I haven't tried to extract the data from the database, would rather leave that as a last resort.

Any other ideas?

Geoff
See if you can find any log files that it spits out, otherwise you're in the dark. my best guess is that seeing as the software is written using the .NET framework there's probably something that has been deprecated and/or removed which was included in a windows update if nothing else has changed on the machine. It might be as simple as just installing an older version of the .NET framework, but hard to tell with no output!

If you can find any logs (or anything printed out if you run the .exe file from a cmd line) stick them here and I'll try and dissect them.

Page 2 of 2 All times are UTC
Powered by phpBB® Forum Software © phpBB Limited
https://www.phpbb.com/